[Resolved] Newsletters Delayed by DST Issue

Incident Report for Letterhead

Resolved

This incident has been resolved.
Posted Mar 10, 2025 - 12:09 EDT

Update

Everything seems to be operating smoothly and we are continuing to monitor. We will resolve this at the top of the hour if there are no further incidents.
Posted Mar 10, 2025 - 11:10 EDT

Monitoring

Newsletters are sending in a timely manner as scheduled, so we are going to update the status to "operational." We will continue to monitor.
Posted Mar 10, 2025 - 09:37 EDT

Update

We have been making sure the delayed newsletters have been sending, and now the delta between the scheduled time and the time they reach audience members is down to minutes. We have also deployed a patch to address the underlying issue.
Posted Mar 10, 2025 - 09:20 EDT

Identified

We have encountered sending delays as a result of Daylight Saving's Time in some timezones. We are presently working to ensure that these newsletters are sent, as well as addressing the underlying problem. Thank you for your patience.
Posted Mar 10, 2025 - 08:13 EDT
This incident affected: Services (Email Service Provider).