Newly sent emails are still periodically delaying. You do not have to send them again, we are continuing to deliver them.
Posted Jul 24, 2026 - 12:58 EDT
Update
The message queue continues to drain and we are still monitoring. Thank you for your patience.
Posted Jul 24, 2026 - 10:09 EDT
Update
The outage appears to be resolved and our services have largely been unaffected. We are changing the various statuses to "Operational" but will leave this status update up for awhile.
Posted Jul 24, 2026 - 09:28 EDT
Update
We are continuing to monitor for any further issues.
Posted Jul 24, 2026 - 09:01 EDT
Monitoring
We are starting to deliver mail that had been affected by that regional outage. We are currently working through the queued messages.
We are continuing to work on a fix for this issue.
Posted Jul 24, 2026 - 07:58 EDT
Identified
The current assessment is that some outbound email delivery is blocked by this outage. Emails are continuing to be accepted and queued internally, and will be delivered as soon as the issue is resolved. You ought to expect that your newsletters stay in a "sending" status for a prolonged period.
Posted Jul 24, 2026 - 07:57 EDT
Investigating
An ongoing AWS US West 2 region outage may result in delivery delays or temporary failures. We are assessing the outage's impact on our own service, actively monitoring the situation, and will provide updates as more information becomes available.
Posted Jul 24, 2026 - 07:23 EDT
This incident affected: Delivery (Outbound Email Deliverability (Shared Pools), Outbound Email Deliverability (Dedicated Pools)), API (Marketing API), Services (Email Service Provider, Metrics), and Applications (Newsletters).