[Resolved] Elevated errors creating organization promotions

Incident Report for Letterhead

Resolved

This incident has been resolved.
Posted Jan 02, 2026 - 15:21 EST

Update

That looks like it did the trick. Upgrading the status of organization promotions to "operational." We'll continue monitoring.
Posted Jan 02, 2026 - 14:48 EST

Monitoring

Our patch is in effect and we are now monitoring for further errors.
Posted Jan 02, 2026 - 14:46 EST

Identified

We've identified the underlying problem and we're now applying a patch.
Posted Jan 02, 2026 - 14:19 EST

Investigating

We are observing in our logs elevated errors when some users are creating organization-level promotions, and we are currently investigating the issue. Apologies for any hassle.
Posted Jan 02, 2026 - 14:11 EST
This incident affected: Applications (Promotions).