[Resolved] Errors Saving While Scheduling

Incident Report for Letterhead

Resolved

This incident has been resolved.
Posted Jul 11, 2026 - 16:20 EDT

Monitoring

We are no longer seeing these elevated errors and thing things look hunky dory. We'll monitor for awhile longer.
Posted Jul 11, 2026 - 15:39 EDT

Investigating

This issue remains intermittently rearing its head, we are still actively triaging. Don't hesitate to reach out to us through chat as needed.
Posted Jul 11, 2026 - 15:14 EDT

Identified

We've identified errors while trying to save while scheduling, which is related to a client-side date validation misstep that is interfering with people's writing. A patch is already in progress.
Posted Jul 11, 2026 - 11:19 EDT
This incident affected: Applications (Composer).