Dynamic Subject Latency in Automations

Incident Report for Letterhead

Resolved

This incident has been resolved.
Posted Aug 03, 2026 - 11:01 EDT

Investigating

We can see latency in dynamic subject generation that may cause automations with dynamic subjects to delay, as it's taking an extra long time for the subjects to write themselves. We are investigating and monitoring the issue. The blast radius is fairly small, but we will go ahead and set the Automation service to a status of "degraded performance."
Posted Aug 03, 2026 - 10:49 EDT
This incident affected: Services (Automation).