All's well. Our provider has addressed the latency issues and we have seen reduced latency on our side.
Posted Dec 15, 2025 - 22:57 EST
Update
Our upstream provider for media transformation (Uploadcare) is still experiencing latency. Expect uploads to take longer than normal, and sometimes fail. If they do fail, try again.
Posted Dec 15, 2025 - 19:44 EST
Update
We're still seeing errors in our logs and so we are resetting the status to "degraded performance."
Posted Dec 15, 2025 - 17:14 EST
Monitoring
Good news 👀. A fix has been implemented. We will be monitoring results.
Posted Dec 15, 2025 - 17:01 EST
Update
It's been a moment since our provider announced that they were implementing a fix. They haven't made any announcement themselves since, but we're noticing fewer errors on our end.
Posted Dec 15, 2025 - 15:24 EST
Update
Our upstream provider has identified the issue and is implementing a fix.
Posted Dec 15, 2025 - 14:29 EST
Update
We have identified that the issue is related to our CDN provider, upstream from us. We will continue to monitor. Apologies for the inconvenience.
Posted Dec 15, 2025 - 14:04 EST
Identified
We are experiencing higher latency when uploading images, to the extent upload are taking a significant amount of time to finish or they fail.
Posted Dec 15, 2025 - 13:17 EST
This incident affected: Applications (Composer, Promotions).