Human Support Chat Latency

Incident Report for Letterhead

Resolved

Everything's back in place. Come chat with us.
Posted Aug 20, 2026 - 13:11 EDT

Identified

Our support chat is currently experiencing some pretty extreme latency that may cause chats to fail. As we address this, to talk to someone in the meantime email support@tryletterhead.com.
Posted Aug 20, 2026 - 12:52 EDT
This incident affected: Services (Customer Support and Ticketing).