Elevated Curation Error Rates

Incident Report for Letterhead

Resolved

This incident has been resolved.
Posted Mar 03, 2026 - 14:45 EST

Monitoring

Okie dokie. It looks like all things are back to normal. We'll keep monitoring.
Posted Mar 03, 2026 - 14:20 EST

Update

Just confirming that this may cause issues when previewing newsletter templates using curation blocks. A patch is deploying.
Posted Mar 03, 2026 - 14:04 EST

Identified

We've noticed a spike of errors related around curation fetching. We believe we've already identified the underlying issue.
Posted Mar 03, 2026 - 13:51 EST
This incident affected: Services (Curation) and Applications (Newsletters).