Degraded performance
Incident Report for Letterhead
Resolved
This incident has been resolved.
Posted Jul 26, 2024 - 17:44 EDT
Identified
We have identified an upstream provider outage that is impacting us and causing intermittent performance issues on our site. Please reach out to us via email at support@tryletterhead.com, and our team will prioritize any support requirements until the outage is resolved by our provider.
Posted Jul 25, 2024 - 11:13 EDT
Update
We have disabled the chat option since we believe our third-party chat provider may be impacting site performance. We will continue to troubleshoot, but please reach out to us via email at support@tryletterhead.com, if you need to reach out to our team while we address this issue.
Posted Jul 25, 2024 - 10:49 EDT
Investigating
We have received reports of degraded performance during the login process. Our team is currently investigating, and we will provide an update as soon as possible. Thank you in advance for your patience.
Posted Jul 25, 2024 - 10:45 EDT
This incident affected: Applications (Archives, Audience, Composer, Dashboards, Promotions, Newsletters).