Elevated Error Rates with Letter Settings

Incident Report for Letterhead

Resolved

This incident has been resolved.
Posted Jun 15, 2026 - 16:19 EDT

Identified

We've identified an issue causing the changing or setting of a newsletter's settings to fail. We are already addressing the problem. Thank you for your patience.
Posted Jun 15, 2026 - 15:42 EDT
This incident affected: Applications (Newsletters).