Our service provider is experiencing intermittent outages, preventing out Storefront and Dashboard from resolving.
Incident Report for Letterhead
Resolved
This incident has been resolved.
Posted Jun 05, 2021 - 17:06 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 05, 2021 - 17:05 EDT
Identified
Our service provider is experiencing intermittent outages, preventing out Storefront and Dashboard from resolving. Our APIs and other services are unaffected, but users may not be able to access their dashboard until our service provider's outages are resolved. See https://status.digitalocean.com for more.
Posted Jun 05, 2021 - 12:28 EDT
This incident affected: Apps (Marketplace, Creator dashboard).