Issue publishing newsletters to Mailchimp
Incident Report for Letterhead
Resolved
Everything looks okay from the Mailchimp end of things.
Posted Apr 14, 2021 - 12:32 EDT
Update
Mailchimp has reported they have resolved their connection issues. We're now monitoring sending from Letterhead.
Posted Apr 14, 2021 - 11:37 EDT
Update
Mailchimp's still working on the connection issues, so we're still monitoring. For anyone affected, our recommendation is to wait. Often when Mailchimp has this kind of issue, once resolved they will then proceed to resolve their queues.
Posted Apr 14, 2021 - 11:04 EDT
Monitoring
Mailchimp is having technical difficulties (https://status.mailchimp.com/) and has affected Letterhead's ability to publish to Mailchimp servers in the US1 region.
Posted Apr 14, 2021 - 10:31 EDT
This incident affected: Applications (Newsletters).