Promotion metrics display error
Incident Report for Letterhead
Resolved
This incident has been resolved.
Posted Sep 26, 2022 - 08:56 EDT
Identified
Individual promotion clicks and views not always displaying correctly. This is a display issue only. We are working to resolve it.
Posted Sep 21, 2022 - 10:36 EDT
This incident affected: Applications (Promotions).