[Resolved] Cloudflare Global Outage (Emails, Curations)

Incident Report for Letterhead

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 12:01 EST

Monitoring

After a long morning, things appear hunky dory. We are still wrangling the stray delays and proactively communicating out with users, but all in all services appear to be normalizing.
Posted Nov 18, 2025 - 10:59 EST

Update

It does indeed seem that Cloudflare has implemented a sufficient fix and our services are restoring. There are a lot of transactions that need to catch-up, and now the work is ensuring restoration is smooth. I have upgraded the statuses of applications and services from "Major Outage" to "Degraded Performance."
Posted Nov 18, 2025 - 10:12 EST

Update

Cloudflare has just published a fix, so we are going to optimistically start flipping switches.
Posted Nov 18, 2025 - 09:57 EST

Update

While Cloudflare's status hasn't meaningfully changed, we have performed some triage to ensure the restoration of services are smooth. That is: curations and automations are more likely to pick up where they left off - delayed, but not skipped.
Posted Nov 18, 2025 - 08:39 EST

Identified

Updated our list of impacted services. Thanks for your understanding. Cloudflare is used by many upstream providers, hosts, and the like. While there may be specific services affected, if you want to stay on top of the situation we recommend referring to: https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 08:06 EST

Investigating

Cloudflare, an upstream provider of even the most upstream providers, is experiencing a global network issue (https://www.cloudflarestatus.com/), which is impacting our ability to generate templates. This will prevent recurring newsletter automations from sending, as well as prevent users from progressing to the scheduling step when creating an individual edition.
Posted Nov 18, 2025 - 07:50 EST
This incident affected: Applications (Audience, Composer, Newsletters) and Services (Automation, Curation, Email Service, Metrics).